Usare un editor di testo per il codice HTML

Mi sono appena accorto che Firefox 2.0 offre la possibilità di utilizzare un editor esterno per visualizzare l’HTML di una pagina web, cosa che nelle versioni precedenti era possibile solo mediante l’installazione di ViewSourceWith. Per attivare questa funzione bisogna digitare about:config nella barra degli indirizzi e modificare queste due chiavi come segue:
view_source.editor.external a true
view_source.editor.path, al percorso dell’eseguibile dell’editor di testo, io ad esempio ho messo C:\Programmi\Crimson Editor\cedt.exe.

Che equivale ad aggiungere al file user.js il seguente codice:

user_pref("view_source.editor.external", true);
user_pref("view_source.editor.path", "C:\\Programmi\\Crimson Editor\\cedt.exe");

:
NOTA: Nel file user.js i cammini vanno riportarti usando la doppia \\ e non la \ singola.

AGGIORNAMENTO: A dir la verità funziona su tutte le pagine che ho provato meno che quella principale del Blog !! Sinceramente non ne capisco il motivo visto che la pagina di Login viene aperta con l’editor selezionato mentre quella principale dall’editor di default di Firefox. Boh !!

AGGIORNAMENTO: Dopo aver aperto un Topic su MozillaZine sembra che il motivo per cui in alcune pagine non viene utilizzato l’editor esterno sia dovuto ad un problema di encoding, Bug: 347047. Per una strana ironia della sorte il comportamento erroneo si verifica sul permalink di questa notizia :-S.

AGGIORNAMENTO: Anche sostituendo il contenuto QuickTime con un video in Flash non cambia nulla.
AGGIORNAMENTO: probabilmente se si prova ad applicare quanto detto in questo post sulla pagina di questo blog si otterà l’apertura del programma selezionato, ma si avrà un errore di file non trovato. Credo che sia un bug di Firefox che devo accertare e magari segnalare su Bugzilla. Il problema è legato alla nuova codifica utilizzata (UTF-8) e al carattere ‘è’ presente nel titolo della pagina.

10 Responses to “Usare un editor di testo per il codice HTML”


  • In 5 secondi ho fatto tutto.
    1)Click su view….external, e da false il boolean
    è passato a true
    2) Click su view…path, sulla riga ho inserito
    il percorso del mio editor C:\MENU'\tdew.exe
    Grazie, Sandro

  • Se fai (CTRL-U) non si apre il tuo editor ?
    In effetti qualche BUG aperto ci deve essere, se cerco di visualizzare il codice della pagina iniziale del Blog si apre il solito Editor standard di Firefox, con altre pagine si apre quello che avevo impostato.
    Io finora ho notato il malfunzionamento solo con quella pagina con le altre funziona.
    Ciao

  • Non credo ci sia alcun bug. Appena io dò CTRL-U mi si apre la mascherina colorata del mio editor tdew.exe.
    Ho notato che tu hai linkato il tuo editor con C:\\…, ovvero
    con due barrette, ripetute in due parti, invece che con una come ho
    fatto io: C:\MENU'\tdew.exe.
    Il tutto mi funziona bene, sia con CTRL-U che con la selezione dal
    comando di visualizzazione. Fammi sapere.
    Ciao

  • Anche a me funziona su tutte le pagine MENO la pagina principale di questo Blog:
    http://www.gialloporpora.netsons.org/Blog

    La doppia "\" l'ho usata nel file user.js ma quella é una convenzione non quando ho modificato le chiavi da about:config, se avessi fatto un errore simile non funzionerebbe nemmeno con le altre pagine.
    Se fai (CTRL-U) sulla pagina principale riesci ad aprire l'editor esterno ?
    Ho scritto anche su MozillaZine sperando non lo vedano come tentativo di spam.
    Ciao

  • Se clicco su questo link
    http://www.gialloporpora.netsons.org/Blog
    mi si apre un altro editor (quello classico)
    che non si riesce poi a modificare, mentre per il resto tutto
    procede bene.
    In effetti il problema esiste proprio per quella pagina
    Ciao

  • Sono ancora io. Forse è un problema di QuickTime.
    Il suo logo appare in sottoimpressione appena si apre
    il tuo sito.
    Ciao

  • Si, sinceramente credevo anch'io fosse dovuto al contenuto multimediale che avevo inserito e la prima cosa che difatti ho provato é vedere se anche la pagina da cui ho copiato il codice:
    http://www.firefoxflicks.com/flick/index.php?id=19542&c=false
    presentasse lo stesso problema e invece quella pagina si comporta come tutte le altre.
    Speriamo che qualcuno mi risponda su MozillaZine anche se magari lo prendono come un tentativo di di fare pubblicità alla mia home page e ignorano la richiesta.
    Quando uscirà la versione ufficiale proverò su MozillaItalia per vedere cosa ne pensano.
    Ciao
    Sandro
    PS: la mail non serve la metti commenti lo stesso

  • Adesso Ctrl+U della main page di "Il Blob che non c'è" funziona, ma il mio editor prescelto (tde) mi segnala una pagina vuota. Presumo per tua scelta.
    Ciao

  • Ciao,
    ho notato anch'io che ora non lo fa più dopo l'aggiunta dell'ultima notizia in compenso ora accade con questa pagina:
    http://www.gialloporpora.netsons.org/Blog/index.php?entry=entry061003-001700
    il contenuto QuickTime comununque é presente su entrambe, proprio non riesco a capire dove sta il problema !!!
    Io non ho fatto niente al codice a me appare tranquillamente, il Blog comunque é un blog preconfezionato io mi limito ad aggiungere notizie dal form apposito senza quasi mai toccare il codice HTML (PHP).
    Ciao

  • Alla fine mi hanno risposto e sembra esista già un BUG su Bugzilla a riguardo:
    Bug: 347047

Leave a Reply